Knowledge Base

Follow

Apple macOS X 10.15 Compatibility Statement

Apple is poised to release its next operating system, macOS X 10.15, “Catalina,” sometime in October of 2019. PreSonus has been working with Apple to qualify pre-release versions of this new OS with all of our products. 

We have found changes in Catalina that affect compatibility with PreSonus hardware and software. Remain on current versions of macOS until further notice. We ask that you please wait for us to announce compatibility before updating your OS. 

In the meantime, please be advised: 

  • Studio One version 4.5.4 is required to run Studio One under 10.15. 
    • Izotope Neutron Elements and Klanghelm SDRR2Tube will not install under 10.15. 
    • Arturia Analog Lite, and StudioLinked Trophies will at first not install— you must CTRL+Click (or right click) and select “Open” to install them. 
    • Check your third-party plug-in developers’ websites for updates, as many of them may not install or run correctly under 10.15, and will need updates themselves to work correctly. 
    • Some of the Studio Magic Plug-ins will not run under 10.15. 
  • Notion 6.5.470 is required to run under 10.15
    • Check your third-party plug-in developers’ websites for updates, as many of them may not install or run correctly under 10.15, and will need updates themselves to work correctly.
  • Universal Control 3.1 and older versions are not supported and will not open sample rate settings correctly on macOS X 10.15 Catalina. 
    • An update to Universal Control will be necessary to access these settings. This update will be announced as soon as it’s ready for use with 10.15. 
  • Universal Control 1.7.6 for FireStudio interfaces and StudioLive 24.4.2, 16.4.2 and 16.0.2 will not install on macOS X 10.15 Catalina.
    • An update to Universal Control will be announced as soon as it’s ready for use with 10.15. 
  • StudioLive Series III mixers will not work with macOS X 10.15 without a firmware update. 
    • We are planning a public beta of this firmware update to be available soon after 10.15 becomes available. 
  • StudioLive 16.0.2. USB will not work with 10.15, please stay on 10.14 or a previously-supported OS until further notice. 

We will provide an update when we have qualified 10.15 for use with our products and what updates are needed to ensure proper compatibility. 

Thank you!

PreSonus Team

 

Please also see the following article: 

https://support.presonus.com/hc/en-us/articles/360033107871-Studio-One-4-on-Mojave-and-Catalina-Notarization-Hardened-Runtime-and-how-it-affects-3rd-party-plug-ins

 

Was this article helpful?
4 out of 5 found this helpful
Have more questions? Submit a request
Powered by Zendesk