Knowledge Base


Notion and Studio One Integration Explained

Although Notion and Studio One have many tools that can compliment one another, such as exporting .wav files, exporting MIDI files, and exporting Capture files, there are 3 main ways to integrate Notion with Studio One.

Setting up both programs:

1.  Open Notion and go to File>Preferences>General.  (Notion>Preferences>General on a Mac)  Check the box that reads "Allow Network Discovery."  Close and re-open Notion.

2.  Open Studio One with Notion closed and go to Studio One>Options (Preferences on Mac)>General>Networking and check the box to "Allow remote control apps to discover this daw."


1.  Sending Notes:

Notion => Studio One:

If you have created a score in Notion and you would like to send it to Studio One, you can do so by going to File>Send to Studio One.  Once you have done this, you will see the following screen:


Click the link to launch Studio One.  Once you do so, you will see the following screen:


On this screen, choose the option to "Send Notes."  You will notice that at the top of this screen, you can select the computer that is running Studio One.  This functionality uses a proprietary protocol from PreSonus called UCNet which allows you to send the note data to other computers on your network running Studio One.  If you check the option to "Merge into open document," the note data will be sent to the song that you are currently working with.

***After sending the note data to Studio One, it is sometimes necessary to manually assign the virtual instruments to your tracks.  This can be due to the way that your instruments are named inside of Notion.  Simply drag the virtual instruments from the Browser in Studio One, and drop them on the newly created instrument tracks.  It is not possible to load the Notion sounds into Studio One and it is not possible to load Studio One Sound Sets into Notion.  

Studio One => Notion

If you wish to send note data from Studio One to Notion, simply open your song in Studio One and go to Song>Send to Notion in the menu bar.  You can choose to send all of your instrument tracks, or just those that you have selected in Studio One.

***Important:  If you are sending note data from Studio One to Notion, your tracks in Studio One must be instrument tracks, containing MIDI data.  Notion will not convert audio tracks into notation.  If you have a copy of Melodyne installed on your system, you can use it to convert your audio tracks to MIDI.  Once converted, you can send the new instrument tracks containing MIDI data to Notion and it will be notated.


2.  Sending Audio

When sending audio from Notion to Studio One or from Studio One to Notion, the steps are almost the same as sending note data (outlined above).  You just need to choose the option to send audio instead of sending notes.  When you send audio from Notion to Studio One, each of your instruments in your score will be sent to it's own unique audio track in Studio One.  This allows you to further mix your score before mastering.  When you are sending audio from Studio One to Notion, your audio track will be attached to an empty staff.  This will come from the main output of Studio One and will be a stereo mix.  


3.  ReWire:

Notion can be loaded inside of Studio One as a ReWire instrument.  In Notion, you can go to File>Preferences>General on a Windows machine, or Notion>Preferences>General on a Mac and check the box to enable ReWire.  You will want to close and re-open Notion after doing so.  You can then close Notion, open Studio One first, and then you can load Notion as a ReWire instrument.  Inside of Studio One, Notion will show up in the Browser window under "Instruments."  Here is a screenshot that illustrates where Notion will show up in Studio One as a ReWire instrument.  ReWire creates a link between Studio One and Notion.  You can transfer audio as well as MIDI.  For further information on using ReWire in Notion or Studio One, please consult the reference manual.  You will want to make sure that you have the same audio device/driver set up in both programs, and that you are running the same sample rate in Notion that you are running in your song in Studio One.  



Known issues and troubleshooting this functionality:

-Make sure that you do not have any special characters in the name of your song in Studio One, prior to trying to send notes or audio to Notion.  This will prevent you from being able to.  If there is any question about this, try only using text for the name of the .song file.

-If the transport bar of Studio One controls both programs and you are unable to use Notion by itself, then you will want to disable ReWire in Notion.  This is done under File>Preferences>General on Windows or Notion>Preferences>General on Mac.

-If you are running McAfee as your antivirus program, you will need to go into the application protection settings and allow access to Studio One and Notion.  

-You may want to try disabling all software firewalls as well as antivirus protection if problem persists.

-Here is a link to a knowledge base article with instructions for troubleshooting Studio One Remote.  If you are trying to send note data or audio to a different computer, those troubleshooting steps will also be applicable to your situation.

-If you are having a problem sharing your audio interface/sound card between both programs, please take a look at the following suggestions:

a.  Open Studio One and go to Studio One>Options (Preferences on a Mac)>Audio Setup and check the box to "Release audio device in background."  With this set, Studio One will let go of your audio interface/sound card, when it is not the program that is in focus.  

b.  If you are running Windows, you will want to go into the Windows Control Panel>Sound and open the Preferences for your audio device.  You can then set the sample rate to the same sample rate that you have set for your Studio One song as well as your sample rate in Notion.  The sample rate in Notion is under File>Preferences>Audio on Windows or Notion>Preferences>Audio on Mac.

c. Use an ASIO driver for all applications if possible for best results. 

-If all else fails, try removing the settings files from Studio One and re-configure.  We have seen this resolve connectivity issues between Notion and Studio One in the past.

  1. Go to Help>Open Settings folder.

  2. Copy the contents of the folder over to a folder on your desktop.

  3. Close S1 and delete the contents of the settings folder with the exception of the user.license file as well as the "Extensions" folder.

  4. Open S1 and go to Studio One>Options (Preferences on a Mac) to reconfigure your settings.

  5. Test to see if the problem is resolved. If it is not, please feel free to copy your settings files back over from the backup that you created in step 2.


*If you are missing presets or Sound Sets after doing this, simply double-click one of your Sound Sets under Documents>Studio One>Sound Sets.












Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request
Powered by Zendesk