Knowledge Base

Follow

How can I get my 3rd-party plug-ins to show up in Studio One?

***If you are running an M1 Mac with Studio One 5.4 or higher and are missing plug-ins, it is possible that your plug-ins are not natively supported on Apple Silicon systems.  The following article will give you instructions for running Studio One in Rosetta mode. 

https://support.presonus.com/hc/en-us/articles/4407850496141-How-to-switch-from-native-Apple-Silicon-support-to-Rosetta-mode 

 

Windows Plug-in Install

While installing the plug-in to your Windows computer, the installer usually will ask you where you want to install the actual plug-in. On Windows, you can choose the location where the plug-in installs. Make sure that you note that location so that you can set that location in Studio One. Check with your 3rd party plug-in vendor for instructions on installing the plug-in if you run into an issue with the install.

Windows users: From within Studio One, navigate to the Options > Locations, and select the VST Plugins tab. By default, Studio One will have C:\Program Files\Vstplugins as the default location.  You can also use the Add button to add custom locations. 

If the plug-in you are installing has a VST3 version, it will install to C:\Program Files\Common Files\vst3. You do not have to add this path to the plug-in window in Studio One. Studio One by default will scan that folder.  

*** VST3 plugins will only load from c:\Program Files\Common Files\VST3 not from any other folder.

***Important Note for Windows Users: NEVER add the entire Program Files folder or  your entire c: drive to your Studio One>Options(Preferences on a Mac)>Locations list. This will cause the software to crash.  

VSTpluginsBLOCKlistnoArrow.jpg

 

macOS Plug-in Install

macOS users: From within Studio One, navigate to Studio One>Preferences>Locations and select the VST Plug-ins tab.  When you install plug-ins, the VST will automatically install to Macintosh HD/Library/Audio/Plug-ins/VST or VST3.  If you set a custom location, make sure to add it to the VST Plug-ins list in Studio One.  AU plug-ins, also called Components are set by default in Studio One to be scanned from Macintosh HD/Library/Audio/Plug-ins/Components.  You do not have to set this location to read the AU plug-ins.

***It is possible that a plug-in is installed into Users/Username/Library/Audio/Plug-ins/VST if you choose to only allow a plug-in to be available for the current user.  This is only for VST 2.4.  Library in this directory path is a hidden folder and can be accessed by going to "Go" in the Finder menu bar and holding down the "Option" key on your computer keyboard.  

MacOS.jpg

 

Troubleshooting 3rd-party plug-ins that are not showing up in Studio One.

Studio One 5 has a plug-in scanner that allows you to skip or disable plug-ins.  For more information on managing this plug-in scanner, please take a look at the following article from our knowledge base.

https://support.presonus.com/hc/en-us/articles/360004055292-What-is-the-difference-between-skip-and-disable-in-the-new-plug-in-scan-and-how-do-I-manage-my-plug-ins-now-

Below you will find information on troubleshooting third-party plug-ins that are not showing up in Studio One 5.  

Windows:

  1. Please open Studio One and go to Studio One>Options>Locations>VST Plugins and verify that you have the correct directory added to the list of folders that the program scans at startup. You want to add the directory that you have your plug-ins installed to.  Press the "Reset blocklist" button while you are in this window.

  2. Right-click Studio One and choose "Run as administrator" when opening the program to determine if there is a possible permissions problem.

  3. Studio One 5 will only load 64-bit plug-ins, as it is a 64-bit app. If you loaded your VSTs from the c:\Program Files (x86) folder into Studio One under the "Locations" tab, this is more than likely your 32-bit plug-ins. Your 64-bit plug-ins should be installed under the c:\Program Files directory, without the (x86) next to it.  

  4. Please go to View>Plugin Manager and make sure that there is a white dot next to the plug-in, if it shows up in the list.

  5. In Studio One 5, go into View>Plug-in Manager.  Try resetting the blocklist as well as pressing the button to clear your plug-in settings.
  6. If you are still having a problem, try contacting the manufacturer of the plug-in for information about updates, compatibility issues with Studio One, or possible workarounds.

 

macOS:

  1. Please open Studio One and go to Studio One>Preferences>Locations>VST Plugins and verify that you have the correct directory added to the list of folders that the program scans at startup. You want to add the directory that you have your plug-ins installed to. 

  2. Studio One 5 will only load 64-bit plug-ins as it is a 64-bit app.

  3. Please go to View>Plugin Manager and make sure that there is a white dot next to the plug-in, if it shows up in the list.

  4. In Studio One 5, go into View>Plug-in Manager.  Try resetting the blocklist as well as pressing the button to clear your plug-in settings.
  5. If you are still having a problem, try contacting the manufacturer of the plug-in for information about updates, compatibility issues with Studio One, or possible workarounds.

 

***On macOS, if you have a problem where only AU plug-ins are loading, this can sometimes be caused by a corrupt hosts file on the system.  Here are instructions to resolve this issue...

 

1.  Download the attached, healthy, hosts file from this article at the bottom.
2.  On the afflicted computer, you can go to "Go" in the Finder menu bar and choose "Go to Folder."
3.  In the "Go to Folder" window, type in /private/etc/hosts and press "Go."  This will take you to the location of the Hosts file.
4.  Once in the "etc" folder that holds the "hosts" file, drag the healthy hosts file from this article into it.  When asked if you would like to replace, choose to do so.  
5.  Open Studio One and go into View>Plug-in Manager.  Reset the blocklist as your plug-ins were probably added to the list previously.
6.  Restart Studio One.
***If the issue persists, reboot the computer.  You can also try clearing your dns cache with the following Terminal command if needed.
sudo killall -HUP mDNSResponder

 

For information on using a memory bridge to load 32-bit plug-ins into a 64-bit host, please refer to the following article:

https://support.presonus.com/hc/en-us/articles/360003940771-Is-there-a-32-bit-version-of-Studio-One-4-How-do-I-load-my-32-bit-plug-ins-

 

Was this article helpful?
2 out of 3 found this helpful
Powered by Zendesk