Knowledge Base

Follow

How can I get my 3rd-party plug-ins to show up in Studio One?

Important Note for Studio One Artist Users: 3rd party VST/AU/Rewire integration is not supported in Studio One Artist versions 3 or version 4, with the exception of the Studio Magic Bundle. You would need either Studio One 3/4 Professional or have purchased the AU/VST and Rewire Support add-on. (https://shop.presonus.com/VST-and-AU-and-Rewire-Support)

 

Windows Plug-in Install

While installing the plug-in to your Windows computer, the installer usually will ask you where you want to install the actual plug-in. On Windows, you can choose the location where the plug-in installs. Make sure that you note that location so that you can set that location in Studio One. Check with your 3rd party plug-in vendor for instructions on installing the plug-in if you run into an issue with the install.

Windows users: From within Studio One, navigate to the Options > Locations, and select the VST Plugins tab. By default, Studio One will have C > Program Files > Vstplugins as the default location.  You can also use the Add button to add custom locations. 

If the plug-in you are installing has a VST3 version, it will install to C > Program Files > Common Files > vst3. You do not have to add this path to the plug-in window in Studio One. Studio One by default will scan that folder.

***Important Note for Windows Users: NEVER add the entire Program Files folder to your Studio One\Locations list. This will cause the software to crash, you MUST add the top level folder that contains the dll file or add a shortcut to the top level folder of the DLL file to the Program Files vst folder that is listed by default in the Program Files section of your C drive.***

 Windows.jpg

 

Mac OS Plug-in Install

Mac OS users: From within Studio One, navigate to Preferences > Options > Locations, and select the VST Plug-ins tab.  On Mac OS, when you install the plug-in, the VST will automatically install to Users > username > Library > Audio > Plug-ins > VST. If you set a custom location, make sure to add it to the VST Plug-ins list in Studio One. AU plug-ins, also called Components are set by default in Studio One to be scanned from Users > username > Library > Audio > Plug-ins >Components. You do not have to set this location to read the AU plug-ins.

MacOS.jpg

 

Troubleshooting 3rd-party plug-ins that are not showing up in Studio One.

Studio One 4 now has a new plug-in scanner that allows you to skip or disable plug-ins.  For more information on managing this plug-in scanner, please take a look at the following article from our knowledge base.

https://support.presonus.com/hc/en-us/articles/360004055292-What-is-the-difference-between-skip-and-disable-in-the-new-plug-in-scan-and-how-do-I-manage-my-plug-ins-now-

Below you will find information on troubleshooting third-party plug-ins that are not showing up in Studio One 4.  

Windows:

  1. Please open Studio One and go to Studio One>Options>Locations>VST Plugins and verify that you have the correct directory added to the list of folders that the program scans at startup. You want to add the directory that you have your plug-ins installed to. If you do not see the "VST Plug-ins" tab under the Locations tab, then you want to make sure that you have activated Studio One Professional or you have installed the VST, AU, and ReWire support add-on if you are running the "Artist" version of Studio One. Press the "Reset Blacklist" button while you are in this window.

  2. Right-click Studio One and choose "Run as administrator" when opening the program to determine if there is a possible permissions problem.

  3. Studio One 4 will only load 64-bit plug-ins, as it is a 64-bit app. If you loaded your VSTs from the c:\Program Files (x86) folder into Studio One under the "Locations" tab, this is more than likely your 32-bit plug-ins. Your 64-bit plug-ins should be installed under the c:\Program Files directory, without the (x86) next to it.  

  4. Please click the icon of the wrench in the browser window, at the top, right-hand corner of the window, to open the plug-in manager. Make sure that there is a white dot next to the plug-in, if it shows up in the list.

  5. In Studio One 4, go into View>Plug-in Manager.  Try resetting the Blacklist as well as pressing the button to clear your plug-in settings.
  6. If you are still having a problem, try contacting the manufacturer of the plug-in for information about updates, compatibility issues with Studio One, or possible workarounds.

 

Mac OS:

  1. Please open Studio One and go to Studio One>Preferences>Locations>VST Plugins and verify that you have the correct directory added to the list of folders that the program scans at startup. You want to add the directory that you have your plug-ins installed to. If you do not see the "VST Plug-ins" tab under the Locations tab, then you want to make sure that you have activated Studio One Professional or you have installed the VST, AU, and ReWire support add-on if you are running the "Artist" version of Studio One. Press the "Reset Blacklist" button while you are in this window.

  2. Studio One 4 will only load 64-bit plug-ins as it is a 64-bit app.

  3. Please click the icon of the wrench in the browser window, at the top, right-hand corner of the window to open the plug-in manager. Make sure that there is a white dot next to the plug-in, if it shows up in the list.

  4. In Studio One 4, go into View>Plug-in Manager.  Try resetting the Blacklist as well as pressing the button to clear your plug-in settings.
  5. If you are still having a problem, try contacting the manufacturer of the plug-in for information about updates, compatibility issues with Studio One, or possible workarounds.

 

For information on using a memory bridge to load 32-bit plug-ins into a 64-bit host, please refer to the following article:

https://support.presonus.com/hc/en-us/articles/360003940771-Is-there-a-32-bit-version-of-Studio-One-4-How-do-I-load-my-32-bit-plug-ins-

 

Was this article helpful?
3 out of 14 found this helpful
Have more questions? Submit a request
Powered by Zendesk