Knowledge Base

Follow

FireStudio 2626 - Why won't my FireStudio 2626 work on Windows 8, OSX 10.7 or OSX 10.8?

The FireStudio 2626 is a discontinued device and has limited driver support.
NOTE: The FireStudio 2626 drivers are not supported on Windows 8 or higher or Mac OS X 10.8 or higher.

The latest drivers for this interface are listed below:

 

  • Universal Control 1.2 for PC (Windows XP 32bit only, Windows Vista 32bit / 64bit, Windows 7 32bit / 64bit)  
  • Universal Control 1.2 for Mac (OS X 10.5 Leopard and OS X 10.6 Snow Leopard)
  • FireControl in conjunction with UC 1.6.1 (OS X 10.7 Lion only)

    Please see release notes here for more inforamtion.  Note that Firmware updates cannot be completed with FireControl on OS X Lion, only UC 1.2 Control Panel.

 

Download drivers for The FireStudio 2626 here.  

 

Note: If you have had a newer version of Universal Control installed then you must uninstall the newer one before installing 1.2. 

If you have updated to OS X 10.7 Lion from a previous version of OS X that had Universal Control 1.2 installed then you will need to uninstall version 1.2 and then install FireControl.

Manual removal of Universal Control 1.2:

http://support.presonus.com/entries/113168-FireStudio-Family-How-do-I-Uninstall-Reinstall-my-FireStudio-drivers-on-a-Mac-computer- 

 

Support and Service for the FireStudio 2626 has ended as of 6/30/15.

**This is noted on our Service Page

http://www.presonus.com/support/repairs 

 

 

Was this article helpful?
6 out of 6 found this helpful
Have more questions? Submit a request
Powered by Zendesk